Fail to run IP calculations in parallel

Various technical topics such as parallelism and efficiency, netCDF problems, the Yambo code structure itself, are posted here.

Moderators: Davide Sangalli, andrea.ferretti, myrta gruning, andrea marini, Daniele Varsano, Conor Hogan, Nicola Spallanzani

Post Reply
Jessie
Posts: 1
Joined: Tue Nov 07, 2023 1:53 pm

Fail to run IP calculations in parallel

Post by Jessie » Thu Nov 23, 2023 8:57 am

Dear all,

I was trying to follow the steps in the tutorial https://www.yambo-code.eu/wiki/index.ph ... n_parallel to run an IP calculation in parallel, but it has failed. I also tried to run an RPA calculation and the same error occured. Here is the error information in the log files

Code: Select all

P1: [ERROR] STOP signal received while in[04] Dipoles
P1: [ERROR] Writing File ./IP_mpi8//ndb.dipoles; Variable  NOT DEFINED; NetCDF: Parallel operation on file opened for non-parallel access
and the error information on my screen:

Code: Select all

--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 4 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
[localhost.localdomain:42104] PMIX ERROR: UNREACHABLE in file server/pmix_server.c at line 2198
[localhost.localdomain:42104] 1 more process has sent help message help-mpi-api.txt / mpi-abort
[localhost.localdomain:42104] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages
The version of my yambo code is MPI+HDF5_MPI_IO - Ver. 5.1.0 and the code was installed by conda. The task has been run in the following steps:

1. yambo
(initialization)
2. yambo -o c -V par -F yambo_IP.in
(However, in this step, I didn't find variables named "X_Threads" and "DIP_Threads" which are mentioned in the tutorial webpage above, so I didn't change any variables about parallel in the input file.)
3. mpirun -np 8 yambo -F yambo_IP.in &

Could you give me some instructions to solve this error? Thanks.

Best regards,
Jessie
You do not have the required permissions to view the files attached to this post.
Jessie
Postgraduate student
Department of Materials Science
Fudan University

User avatar
Daniele Varsano
Posts: 3926
Joined: Tue Mar 17, 2009 2:23 pm
Contact:

Re: Fail to run IP calculations in parallel

Post by Daniele Varsano » Thu Nov 23, 2023 9:06 am

Dear Jessie,

it seems you have an I/O problem. It could be related to some conflict with the used parallel compiler and the mpirun you are using to launch the job.
In any case, I suggest you to update to the latest version of the code and try again. If the problem persists we will insoect it in more details.
Best,
Daniele
Dr. Daniele Varsano
S3-CNR Institute of Nanoscience and MaX Center, Italy
MaX - Materials design at the Exascale
http://www.nano.cnr.it
http://www.max-centre.eu/

Post Reply